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1 Introduction 
CODEX High Density Encoding (HDE) is a lossless, variable bitrate encoding scheme, optimized for Bayer 
pattern images, such as ARRIAW. The file size of a high density encoded ARRIRAW clip, on the average, is 
50 to 60% of its original size, depending on the image content. Once decoded, the images deliver a bit-exact 
match to the original uncompressed ARRIRAW images. While CODEX originally created HDE to support 
ALEXA 65 productions, it’s regularly used on projects shooting ARRIRAW with any of our cameras today. 

The ALEXA 35 records its images inside an MXF clip, as described in two SMPTE Registered Disclosure 
Documents (RDD 54 and 55). This significantly reduces redundancy as static metadata is only recorded once 
per clip, not with every frame. ALEXA 35 processing is fully aligned towards metadata transport in an MXF 
container. Single frame ARRIRAW and HDE therefore is only available for earlier camera models. 

High Density Encoding to .ARX file sequences is available exclusively from CODEX Device Manager and 
supported for ALEXA XT, SXT, LF, AMIRA, ALEXA Mini and Mini LF. 
HDE output as MXF is available from the ARRIRAW HDE Transcoder and CODEX Device Manager 7.  

2 HDE Transcoding Options 
ALEXA 35 customers have two options to convert MXF/ARRIRAW files to MXF/HDE files: 
The CODEX Device Manager 7 (and later) or the ARRIRAW HDE Transcoder. 

• CODEX Device Manager is a free system extension for macOS which can automatically present a (virtual) 
HDE drive when a CODEX drive containing ARRIRAW data is mounted. The HDE drive can be accessed 
with commonly used data wrangling tools. As the files are read, the CODEX software then actually 
transcodes them to HDE on the fly. 

• The ARRIRAW HDE Transcoder uses the original CODEX HDE encoder, but a different approach. The 
free standalone software offers an interface where you select a CODEX drive or any folder containing the 
ARRIRAW data and one or more destinations where the HDE output will be written to. This process does 
not rely on a data wrangling tool. To support verification processed, the software also offers mhl v1 or 
ascmhl v2 hash list creation. 

3 ARRIRAW HDE Transcoder 
The ARRIRAW HDE Transcoder is available for macOS and Windows with user interface and for macOS, 
Windows, and CentOs 7 as a command line version. The command line version of the transcoder accepts 
batch preocessing, and also allows transcoding of individual files rather than only directories. 

 File name and Clip Name 
Since ALEXA 35 MXF files can contain Apple ProRes images, uncompressed ARRIRAW data or ARRIRAW 
data with High Density Encoding, we use an image encoding character in the file name as a visual aid. 

A_1234C345_YYMMDD_HHMMSS_p6ZJA.mxf = Apple ProRes 
A_1234C345_YYMMDD_HHMMSS_a6ZJA.mxf = ARRIRAW  
A_1234C345_YYMMDD_HHMMSS_h6ZJA.mxf = HDE 
 

File name and clip name mean the same thing, but are actually two individual entries in the clip metadata. 
Both are also referenced in the ALE file. When an ARRIRAW source is transcoded to HDE, the image 
encoding character in the output file name is changed from _a to _h. The ARRIRAW HDE Transcoder also 
will update the corresponding fields in the metadata and update the .ALE file.  
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Note: If the original ARRIRAW file name was modified, so the software cannot detect the image encoding 
character in the right place, the software will append ‘_hde’ to the input file name instead and change 
metadata accordingly. The ALE file, however, will not be modified accordingly. 

 User Interface Operation 
 

 

 

 

 

 

 

 

 

 

 

 

 

• Select a ‘Source’ folder (1) which may contain clips or a folder containing more than one reel of clips. 
ProRes and foreign files will be ignored. The .ale and .bin file will be copied over. 

• Select a ‘Destination’ folder (2) where the encoded output will be written. 
The software will mirror the source directory structure. 

• The ‘Job Name’ (3) is automatically created based on the source folder name, but can be changed. 

• Using ‘Watch Source‘ (4) causes the software to encode all present clips in the source folder and 
then wait for new files to show up. A ‘watch’ job is identified with a pin in the ‘Active’ job list. 

• The Timeout (5) setting can be altered in case of ‘not enough data’ messages due to slow access to 
the source folder. 

• The dropdown menu (6) next to the Timeout setting allows the selection of different hashing formats 
that can be created in the MHL v1 or the ASCMHL v2 format. 

• Use ‘Add Job’ (7) to start the transcoder or add the job to the list of pending jobs. 

• Click the ‘X’ icon (8) in the ‘Active’ job list to abort a running job or cancel a ‘Watch Source’ job. 

• Use ‘Pause Transcoder’ (9) to temporarily stop a job (e.g. to free up CPU). 
The encoder will then finish the current clip and wait until you click the button again to ‘Resume’. 

• ‘Clear History’ will clear the jobs shown in the job ‘History’ list. 

• The application keeps the log files in a system folder. 
Navigate to ‘File > Show Log Files…’ in the menu bar to open this folder. 

• In the application menu ‘File > Output file name:’ toggles between the use of the encoding character 
‘_h’ and the legacy ‘_hde’ suffix. Use of the legacy naming scheme is not recommended. 
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 Command Line Operation 
arrirawhde [options] -i <input file, folder or job.json> -o <output file or folder> 
 options: 
 -a activate watch folder 
 -c <value>-<type> sets the media hash list and checksum type 
     m1 for mhl v1, m2 for ascmhl v2. md5, sha1, sha256, c4, xxh64, xxh3, xxh128 
     Example: -c m2-xxh64 
 -r <path/file> create a json report with specified file name at the specified path 
 -t <value > demux timeout in seconds 
 -l legacy output file name. Appends _hde instead of using the hde identifier _h####.mxf. 
 -v verbose mode 

 -eula print end user license agreement 

Examples 
A Compact Drive named A_0001_12R1 and a shuttle disk called TD1 are mounted on a computer. 
On a Mac, the mount points would be /Volumes/A_0001_12R1/ and  /Volumes/TD1/. 
arrirawhde -i /Volumes/A_0001_12R1/A_0001_12R1/A_0001C001_230504_104800_a12R1.mxf -o /Volumes/TD1/ 

This will cause the software to read only clip A_0001C001_230504_104800_a12R1.mxf from folder A_0001_12R1 on 
the recording media and create an HDE clip named A_0001C001_230504_104800_h12R1.mxf on the shuttle 
disk. 

arrirawhde -v -c m1-xxh64 -i /Volumes/A_0001_12R1/ -o /Volumes/TD1/ 

This will cause the software to show a verbose output in the terminal window, as it reads everything stored 
on the Compact Drive, typically a reel-folder named A_0001_12R1/, and mirror that onto the shuttle disk. 
ALEXA 35 ARRIRAW clips will be transcoded and named as in the example above. The ALE file will be 
patched to reference the output clip name and file name. Other files will be copied. Each file that will be 
hashed in the xxHash 64 format and the hash is stored in an MHL file on the destination.  

4 Known Issues 
ASC Media Hash List and MHL 
If the ARRIRAW HDE Transcoder uses a source volume that already contains a Media Hash List, (i.e. a 1:1 
verified copy of an ARRIRAW drive on some storage device), the software cannot use the media hash list on 
the source side and offer verification. The reason is that the HDE process creates a new compilation of files. 
Apple ProRes clips or other files that may be present in the source folder are copied, but ARRIRAW files 
become new, high density encoded ARRIRAW files. The ALE file also is updated so it will link to the new 
HDE files. Since the hash of different files always is different, it’s pointless to run a verification in this step. 

The mhl and ascmhl feature works as intended if the source of ARRIRAW files is an original CODEX drive. 
The software will create an mhl or ascmhl file next to the HDE content which can be used for verification by 
copy tools down the line. 

Apple command line version does not start 
Ensure that the software is executable to your user. For easy access, you should add the software to 
/usr/local/bin or add the path to your terminal shell start script. On the first start, you will need to access the 
Security panel in System Preferences and allow the execution of the software. 

.ALE Files 
The ALE file is always patched to reference clip names and file names using the _h image encoding 
character, even if the application is set to use the legacy _hde suffix. The command line version always will 
copy the ALE file to the destination, even if a single file is specified as an input. 
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Checksum varies every time a file is encoded 
The MXF specification requires that an MXF file contains a creation and modification time stamp, as well as 
unique identifier. Each of these values are different every time the file is created, so the same applies to the 
resulting checksum. 

HDE CRC image checksum 
HDE output files now include a secondary image checksum to allow for checksum validation of losslessly 
compressed ARRIRAW pictures without the need to invert the lossless encoding. 

The definition still needs to be added to SMPTE RDD 55. Please contact digitalworkflow@arri.de if you 
create software and need assistance to access this information. 
 
macOS Ventura 
If the ARRIRAW HDE Transcoder installation fails on an Apple computer that was updated to macOS 
Ventura, please check that Installer.app has Full Disk Access in System Prefs > Security & Privacy and 
launch the installer .PKG file from within the applications folder. 

Performance issues 

We’ve received reports that a Mac will enter sleep mode if the screen is locked or left unattended for an 
extended period. We currently don’t have a solution for that other than using alternative methods to lock the 
screen (cf. babyproof on the app store). 

If you are using ’Spaces’ on the Mac, the arrirawhde process will be moved to the efficiency cores once the 
focus is moved to another space. To avoid this behaviour, either avoid switching spaces or right click on the 
ARRIRAW HDE Transcoder dock icon and assign the app to all spaces. 

Processing order 
Especially for jobs using the ‘Watch Source’ option, it is possible that the files are not processed in a the 
expected order or no comprehensible order at all. 

Unsupported non-RAW stream type: 48 
This error message will be shown if the source folder contains mixed data, i.e. non-ALEXA 35 
MXF/ARRIRAW files, like MXF/Apple ProRes or other. 
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5 Change Notes 

Version 1.6 
- Bug fixed: wrong bytes 13,14,15 calculation for material and source UMIDs. 
- Improved GUI layout under MacOs. 
- Improved error handling if a destination does not have enough disk space. 
- Added a warning if a multi-destination setup points to the same location more than once. 

Version 1.5 
- Multiple destinations feature added. 
- Bug fixed: the warning dialog does not keep a resized state. 
- Disable a filename suffix changing, ALE patching, clip metadta patching. 
- Bug fixed: truncated output for SHA1 hash. 
- Bug fixed: incorrect C4 calculation for big files. 
- Skip files with name started with '.' 
- C4 hashing now uses always for mhl chain items. 

Version 1.4 
- Output files now include an HDE CRC image checksum (to be added to the RDD) 
- The application now copies and hashes all files from the source path. 
- The _h encoding identifier is now carried forward into the clip name metadata and the ALE file. 
- New hashers added: SHA1, SHA256, C4, XXH3, XXH128. 
- Added maintenance for ascmhl_chain.xml file. 
- Added ascmhl file sequencing. 
- Handling for Ctrl-C and other signals has been added to console application. 
- json report for command line watchfolder mode now updated after each file. 
- Work in progress: Validation, if the source path contains an ascmhl hashlist.   
- The behavior of the processed clip counter has been changed. 

 

Version 1.3 beta 
- The "clear log" button caption changed to "clear history". 
- Keep history unless it is cleared by the user implemented. 
- Spaces into the ìhashlistî tag of ascmhl have removed. 
- Menu: File > Show Log File(s) replacement. 
- Output file name correction to use _h encoding identifier by default instead of _hde suffix. 
- Imprint tool's build number into the mhl/ascmhl. 
- Mhl v1 support added. 
- Checksums for .ale and .bin files calculated now. 
- Preserve Clip (UU)ID in Material Package UID. 
- Bug fixed: "ascmhl conformity - leading zeros of xxhash64 checksums missing". 
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6 References 
ASC Media Hash List: https://theasc.com/asc/asc-media-hash-list and https://github.com/ascmitc/mhl 

SMPTE Registered Disclosure Documents: https://www.smpte.org/standards/document-index/rdd 

RDD 54 - Mapping ARRIRAW Bitstreams into the MXF Generic Container 
RDD 55 - MXF Carriage of ARRI Camera System Metadata 
RDD 51 - High Density Image Encoding for ARRIRAW Files 

For a list of tools supporting ALEXA 35 recording formats, HDE, and look files, please go to 
ARRI.com > Learn & Help > Camera & Workflow > ALEXA 35 Workflows 

To learn more about HDE or to register for the new Device Manager public beta please contact 
support@codex.online. 

 

 


